Skip Ribbon Commands
Skip to main content

The XML document ended unexpectedly

Last Update: 2/14/2017 3:05 PM

​The XML document ended unexpectedly

Resolution:

Please review the following:

  • Check to see if there are any devices or software in the network path that may apply some sort of restriction, for example, firewall, WAN accelerator, packet shaper, or routing device, which could truncate XML responses larger than a certain size.
  • Check the migration error log to determine if the error originates from the Source or Destination system; confirm if (500) Internal Server Error, errors are present before the reported XML error.
  • Check IIS logs for (500) Internal Server Error errors.
  • Check Exchange event logs.
  • Check for ability to access the mailbox via OWA and access to EWS URL.
  • Check authentication settings for the​ /EWS IIS directory.
    • Authentication for EWS:
      • Anonymous - Enabled
      • Basic - Enabled
      • Windows Authentication - Enabled
      • Forms - Disabled (Forms cannot be used)
  • In IIS, double-click on HTTP Response Headers. Under Default Web Site, click on Set Common Headers, and ensure the Enable HTTP keep-alive box is checked.
  • Check the bindings in IIS. In the IIS Manager, navigate to the Default Web Site. Under Edit Site, select Bindings. Ensure that the following two bindings are present. If there are others, note them, and remove them.
                1. Type: https - Hostname: blank - Port: 443 - IP: *
                2 .Type: http - Hostname: blank - Port: 80 - IP: *
  • If the Source is an Exchange 2007 SP2+, check the IIS logs for (500) Internal Server Error, errors for SoapAction=GetItem;Version.

For example:

2017-02-07 00:03:51 192.168.99.99 POST /ews/exchange.asmx SoapAction=GetItem;Version=0;RpcC=7;RpcL=0;LdapC=4;LdapL=47; 443 domainname\admin 192.168.99.88 - 500 0 0 265

This may be the result of performance counters being corrupted. Please review the following Microsoft Knowledge Base (KB) article: Blackberry InternetService (BIS) devices no longer receive email after upgrade to Exchange Server2007 Service Pack 2